NewStart CGSL CORE 5.05 / MAIN 5.05 : rsyslog 漏洞 (NS-SA-2021-0176)

high Nessus 插件 ID 154491

语言:

简介

远程 NewStart CGSL 主机受到一个漏洞影响。

描述

运行 CORE 5.05 / MAIN 5.05 版本的远程 NewStart CGSL 主机上安装的 rsyslog 程序包受到一个漏洞影响:

- 在 4.6.8 之前的 4.6.x 版本以及 5.2.0 到 5.8.4 版本的 rsyslog 中,rsyslogd 内 tools/syslogd.c 的 parseLegacySyslogMsg 函数有一个基于堆栈的缓冲区溢出问题,可能允许远程攻击者通过旧版 syslog 消息中的长 TAG,造成拒绝服务(应用程序退出)。(CVE-2011-3200)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级易受攻击的 CGSL rsyslog 程序包。请注意,更新后的程序包尚未发布。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2021-0176

http://security.gd-linux.com/info/CVE-2011-3200

插件详情

严重性: High

ID: 154491

文件名: newstart_cgsl_NS-SA-2021-0176_rsyslog.nasl

版本: 1.3

类型: local

发布时间: 2021/10/27

最近更新时间: 2023/11/27

支持的传感器: Nessus

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS 分数来源: CVE-2011-3200

CVSS v3

风险因素: High

基本分数: 7.5

时间分数: 6.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:zte:cgsl_core:rsyslog, p-cpe:/a:zte:cgsl_core:rsyslog-crypto, p-cpe:/a:zte:cgsl_core:rsyslog-debuginfo, p-cpe:/a:zte:cgsl_core:rsyslog-doc, p-cpe:/a:zte:cgsl_core:rsyslog-elasticsearch, p-cpe:/a:zte:cgsl_core:rsyslog-gnutls, p-cpe:/a:zte:cgsl_core:rsyslog-gssapi, p-cpe:/a:zte:cgsl_core:rsyslog-kafka, p-cpe:/a:zte:cgsl_core:rsyslog-libdbi, p-cpe:/a:zte:cgsl_core:rsyslog-mmaudit, p-cpe:/a:zte:cgsl_core:rsyslog-mmjsonparse, p-cpe:/a:zte:cgsl_core:rsyslog-mmkubernetes, p-cpe:/a:zte:cgsl_core:rsyslog-mmnormalize, p-cpe:/a:zte:cgsl_core:rsyslog-mmsnmptrapd, p-cpe:/a:zte:cgsl_core:rsyslog-mysql, p-cpe:/a:zte:cgsl_core:rsyslog-pgsql, p-cpe:/a:zte:cgsl_core:rsyslog-relp, p-cpe:/a:zte:cgsl_core:rsyslog-snmp, p-cpe:/a:zte:cgsl_core:rsyslog-udpspoof, p-cpe:/a:zte:cgsl_main:rsyslog, p-cpe:/a:zte:cgsl_main:rsyslog-crypto, p-cpe:/a:zte:cgsl_main:rsyslog-debuginfo, p-cpe:/a:zte:cgsl_main:rsyslog-doc, p-cpe:/a:zte:cgsl_main:rsyslog-elasticsearch, p-cpe:/a:zte:cgsl_main:rsyslog-gnutls, p-cpe:/a:zte:cgsl_main:rsyslog-gssapi, p-cpe:/a:zte:cgsl_main:rsyslog-kafka, p-cpe:/a:zte:cgsl_main:rsyslog-libdbi, p-cpe:/a:zte:cgsl_main:rsyslog-mmaudit, p-cpe:/a:zte:cgsl_main:rsyslog-mmjsonparse, p-cpe:/a:zte:cgsl_main:rsyslog-mmkubernetes, p-cpe:/a:zte:cgsl_main:rsyslog-mmnormalize, p-cpe:/a:zte:cgsl_main:rsyslog-mmsnmptrapd, p-cpe:/a:zte:cgsl_main:rsyslog-mysql, p-cpe:/a:zte:cgsl_main:rsyslog-pgsql, p-cpe:/a:zte:cgsl_main:rsyslog-relp, p-cpe:/a:zte:cgsl_main:rsyslog-snmp, p-cpe:/a:zte:cgsl_main:rsyslog-udpspoof, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

必需的 KB 项: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2021/9/24

漏洞发布日期: 2011/9/1

参考资料信息

CVE: CVE-2011-3200