NewStart CGSL CORE 5.05 / MAIN 5.05 : spice-gtk 漏洞 (NS-SA-2021-0164)

medium Nessus 插件 ID 154504

语言:

简介

远程 NewStart CGSL 主机受到一个漏洞影响。

描述

运行 CORE 5.05 / MAIN 5.05 版本的远程 NewStart CGSL 主机上安装的 spice-gtk 程序包受到一个漏洞的影响:

- spice-0.14.2-1 之前的 SPICE 远程显示系统的 QUIC 图像解码过程中存在多个缓冲区溢出漏洞。SPICE 客户端 (spice-gtk) 和服务器均受这些缺陷的影响。恶意客户端或服务器可利用这些缺陷,发送特别构建的消息,其在由 QUIC 图像压缩算法处理时,会导致进程崩溃或潜在代码执行。
(CVE-2020-14355)

请注意,Nessus 尚未测试此问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

升级易受攻击的 CGSL spice-gtk 程序包。请注意,更新后的程序包尚未发布。请联系 ZTE 获取更多信息。

另见

http://security.gd-linux.com/notice/NS-SA-2021-0164

http://security.gd-linux.com/info/CVE-2020-14355

插件详情

严重性: Medium

ID: 154504

文件名: newstart_cgsl_NS-SA-2021-0164_spice-gtk.nasl

版本: 1.2

类型: local

发布时间: 2021/10/27

最近更新时间: 2021/10/27

支持的传感器: Nessus

风险信息

VPR

风险因素: Medium

分数: 4.9

CVSS v2

风险因素: Medium

基本分数: 6.5

时间分数: 4.8

矢量: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS 分数来源: CVE-2020-14355

CVSS v3

风险因素: Medium

基本分数: 6.6

时间分数: 5.8

矢量: CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:L

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:zte:cgsl_core:spice-glib, p-cpe:/a:zte:cgsl_core:spice-glib-devel, p-cpe:/a:zte:cgsl_core:spice-gtk-tools, p-cpe:/a:zte:cgsl_core:spice-gtk3, p-cpe:/a:zte:cgsl_core:spice-gtk3-devel, p-cpe:/a:zte:cgsl_core:spice-gtk3-vala, p-cpe:/a:zte:cgsl_main:spice-glib, p-cpe:/a:zte:cgsl_main:spice-glib-devel, p-cpe:/a:zte:cgsl_main:spice-gtk-tools, p-cpe:/a:zte:cgsl_main:spice-gtk3, p-cpe:/a:zte:cgsl_main:spice-gtk3-devel, p-cpe:/a:zte:cgsl_main:spice-gtk3-vala, cpe:/o:zte:cgsl_core:5, cpe:/o:zte:cgsl_main:5

必需的 KB 项: Host/local_checks_enabled, Host/ZTE-CGSL/release, Host/ZTE-CGSL/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2021/9/24

漏洞发布日期: 2020/10/6

参考资料信息

CVE: CVE-2020-14355