Foxit PDF Editor < 11.2.2 多个漏洞

high Nessus 插件 ID 160717

简介

远程 Windows 主机上安装的 PDF 工具包受到多个漏洞的影响

描述

根据其版本,远程 Windows 主机上安装的 Foxit PDF Editor 应用程序(旧称 Foxit PhantomPDF)版本低于 11.2.2。因此,该应用程序受到多个漏洞的影响:

- 11.2.2 之前版本的 Foxit PDF Reader 和 PDF Editor 存在类型混淆问题,会因 JavaScript 执行期间未正确处理 Unsigned32 而导致崩溃。 (CVE-2022-30557)

- Foxit PDF Reader 11.2.2 之前版本、PDF Editor 11.2.2 之前版本和 PhantomPDF 10.1.8 之前版本在解析签名文档内的压缩对象期间错误处理交叉引用信息。这会导致攻击者通过增量保存攻击和影子攻击传递错误的签名信息。
(CVE-2022-25641)

- 此漏洞允许远程攻击者在受影响的 Foxit PDF Reader 11.2.1.53537 安装程序上执行任意代码。利用此漏洞需要用户交互,因为目标必须访问恶意页面或打开恶意文件。此特定缺陷存在于文档对象处理进程中。该问题是由于在对某个对象执行操作之前未对其存在性进行验证所致。攻击者可利用此漏洞在当前进程环境中执行代码。此漏洞之前为 ZDI-CAN-16420。(CVE-2022-28669)

- 此漏洞允许远程攻击者在受影响的 Foxit PDF Reader 11.2.1.53537 安装程序上公开敏感信息。利用此漏洞需要用户交互,因为目标必须访问恶意页面或打开恶意文件。AcroForms 的处理中存在特定缺陷。AcroForm 中特别构建的数据可触发读出范围越过已分配的缓冲区末尾。攻击者可利用此漏洞以及其他漏洞在当前进程环境中执行任意代码。此漏洞之前为 ZDI-CAN-16523。(CVE-2022-28670)

- 此漏洞允许远程攻击者在受影响的 Foxit PDF Reader 11.2.1.53537 安装程序上执行任意代码。利用此漏洞需要用户交互,因为目标必须访问恶意页面或打开恶意文件。此特定缺陷存在于文档对象处理进程中。该问题是由于在对某个对象执行操作之前未对其存在性进行验证所致。攻击者可利用此漏洞在当前进程环境中执行代码。此漏洞之前为 ZDI-CAN-16639。(CVE-2022-28671)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级到 Foxit PDF Editor 11.2.2 或更高版本

另见

http://www.nessus.org/u?a27a3e57

插件详情

严重性: High

ID: 160717

文件名: foxit_pdf_editor_11_2_2.nasl

版本: 1.11

类型: local

代理: windows

系列: Windows

发布时间: 2022/5/9

最近更新时间: 2023/10/9

支持的传感器: Frictionless Assessment Agent, Nessus Agent, Nessus

风险信息

VPR

风险因素: High

分数: 8.9

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 4.4

矢量: CVSS2#AV:N/AC:L/Au:N/C:N/I:N/A:P

CVSS 分数来源: CVE-2022-30557

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 7.5

矢量: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:H/RL:O/RC:C

CVSS 分数来源: CVE-2022-28683

漏洞信息

CPE: cpe:/a:foxitsoftware:phantom, cpe:/a:foxitsoftware:phantompdf

必需的 KB 项: SMB/Registry/Enumerated, installed_sw/FoxitPhantomPDF

可利用: true

易利用性: Exploits are available

补丁发布日期: 2022/5/9

漏洞发布日期: 2022/5/9

参考资料信息

CVE: CVE-2022-25641, CVE-2022-28669, CVE-2022-28670, CVE-2022-28671, CVE-2022-28672, CVE-2022-28673, CVE-2022-28674, CVE-2022-28675, CVE-2022-28676, CVE-2022-28677, CVE-2022-28678, CVE-2022-28679, CVE-2022-28680, CVE-2022-28681, CVE-2022-28682, CVE-2022-28683, CVE-2022-30557

IAVA: 2022-A-0211-S