RHEL 8:grub2、mokutil、shim 和 shim-unsigned-x64 (RHSA-2022: 5100)

high Nessus 插件 ID 162328

简介

远程 Red Hat 主机缺少一个或多个安全更新。

描述

远程 Redhat Enterprise Linux 8 主机上安装的程序包受到 RHSA-2022: 5100 公告中提及的一个漏洞的影响。

- grub2:构建的 PNG 灰度图像可能导致堆中发生越界写入 (CVE-2021-3695)

- grub2:构建的 PNG 图像可能在 huffman 表处理期间导致越界写入 (CVE-2021-3696)

- grub2:构建的 JPEG 图像可导致堆中发生缓冲区下溢写入 (CVE-2021-3697)

- grub2:grub_net_recv_ip4_packets 中发生整数下溢 (CVE-2022-28733)

- grub2:处理拆分 HTTP 标头时发生越界写入 (CVE-2022-28734)

- grub2:shim_lock 验证程序允许加载非内核文件 (CVE-2022-28735)

- grub2:grub_cmd_chainloader() 中发生释放后使用 (CVE-2022-28736)

- shim:加载构建的 EFI 图像时发生缓冲区溢出 (CVE-2022-28737)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的程序包。

另见

http://www.nessus.org/u?762f23b3

https://access.redhat.com/security/updates/classification/#important

https://access.redhat.com/errata/RHSA-2022:5100

https://bugzilla.redhat.com/show_bug.cgi?id=1991685

https://bugzilla.redhat.com/show_bug.cgi?id=1991686

https://bugzilla.redhat.com/show_bug.cgi?id=1991687

https://bugzilla.redhat.com/show_bug.cgi?id=2083339

https://bugzilla.redhat.com/show_bug.cgi?id=2090463

https://bugzilla.redhat.com/show_bug.cgi?id=2090857

https://bugzilla.redhat.com/show_bug.cgi?id=2090899

https://bugzilla.redhat.com/show_bug.cgi?id=2092613

插件详情

严重性: High

ID: 162328

文件名: redhat-RHSA-2022-5100.nasl

版本: 1.10

类型: local

代理: unix

发布时间: 2022/6/16

最近更新时间: 2024/4/28

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 6.7

CVSS v2

风险因素: Medium

基本分数: 6.9

时间分数: 5.1

矢量: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

CVSS 分数来源: CVE-2021-3696

CVSS v3

风险因素: High

基本分数: 8.1

时间分数: 7.1

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

CVSS 分数来源: CVE-2022-28733

漏洞信息

CPE: cpe:/o:redhat:rhel_eus:8.2, p-cpe:/a:redhat:enterprise_linux:grub2, p-cpe:/a:redhat:enterprise_linux:grub2-common, p-cpe:/a:redhat:enterprise_linux:grub2-efi-aa64, p-cpe:/a:redhat:enterprise_linux:grub2-efi-aa64-cdboot, p-cpe:/a:redhat:enterprise_linux:grub2-efi-aa64-modules, p-cpe:/a:redhat:enterprise_linux:grub2-efi-ia32, p-cpe:/a:redhat:enterprise_linux:grub2-efi-ia32-cdboot, p-cpe:/a:redhat:enterprise_linux:grub2-efi-ia32-modules, p-cpe:/a:redhat:enterprise_linux:grub2-efi-x64, p-cpe:/a:redhat:enterprise_linux:grub2-efi-x64-cdboot, p-cpe:/a:redhat:enterprise_linux:grub2-efi-x64-modules, p-cpe:/a:redhat:enterprise_linux:grub2-pc, p-cpe:/a:redhat:enterprise_linux:grub2-pc-modules, p-cpe:/a:redhat:enterprise_linux:grub2-ppc64le, p-cpe:/a:redhat:enterprise_linux:grub2-ppc64le-modules, p-cpe:/a:redhat:enterprise_linux:grub2-tools, p-cpe:/a:redhat:enterprise_linux:grub2-tools-efi, p-cpe:/a:redhat:enterprise_linux:grub2-tools-extra, p-cpe:/a:redhat:enterprise_linux:grub2-tools-minimal, p-cpe:/a:redhat:enterprise_linux:shim, p-cpe:/a:redhat:enterprise_linux:shim-aa64, p-cpe:/a:redhat:enterprise_linux:shim-ia32, p-cpe:/a:redhat:enterprise_linux:shim-unsigned-x64, p-cpe:/a:redhat:enterprise_linux:shim-x64

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2022/6/16

漏洞发布日期: 2022/6/16

参考资料信息

CVE: CVE-2021-3695, CVE-2021-3696, CVE-2021-3697, CVE-2022-28733, CVE-2022-28734, CVE-2022-28735, CVE-2022-28736, CVE-2022-28737

CWE: 120, 191, 416, 787, 829

RHSA: 2022:5100