Debian DLA-3307-1:openjdk-11 - LTS 安全更新

low Nessus 插件 ID 171041

简介

远程 Debian 主机上缺少一个或多个与安全性相关的更新。

描述

远程 Debian 10 主机上安装的程序包受到 dla-3307 公告中提及的多个漏洞影响。

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM Enterprise Edition 产品中的漏洞(组件:安全)。受影响的支持版本有 Oracle Java SE:8u341、8u345-perf、11.0.16.1、17.0.4.1、19;Oracle GraalVM Enterprise Edition:20.3.7、21.3.3 和 22.2.0。此漏洞较难受到攻击,其允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 Oracle Java SE 和 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可能导致在未经授权的情况下,即可访问并更新、插入或删除 Oracle Java SE 和 Oracle GraalVM Enterprise Edition 的部分可访问数据。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞也可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。(CVE-2022-21619)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM Enterprise Edition 产品中的漏洞(组件:JNDI)。受影响的支持版本有 Oracle Java SE:8u341、8u345-perf、11.0.16.1、17.0.4.1、19;Oracle GraalVM Enterprise Edition:20.3.7、21.3.3 和 22.2.0。此漏洞较难受到攻击,其允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 Oracle Java SE 和 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可能导致在未经授权的情况下,即可访问并更新、插入或删除 Oracle Java SE 和 Oracle GraalVM Enterprise Edition 的部分可访问数据。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞也可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。(CVE-2022-21624)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM Enterprise Edition 产品中的漏洞(组件:安全)。受影响的支持版本有 Oracle Java SE:8u341、8u345-perf、11.0.16.1;Oracle GraalVM Enterprise Edition:20.3.7、21.3.3 和 22.2.0。可轻松利用的漏洞允许未经身份验证的攻击者通过 HTTPS 进行网络访问,从而破坏 Java SE 和 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可能导致未经授权即可造成 Oracle Java SE 和 Oracle GraalVM Enterprise Edition 部分拒绝服务(部分 DOS)。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞也可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。
(CVE-2022-21626)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM Enterprise Edition 产品中的漏洞(组件:Lightweight HTTP Server)。受影响的支持版本有 Oracle Java SE:8u341、8u345-perf、11.0.16.1、17.0.4.1、19;Oracle GraalVM Enterprise Edition:20.3.7、21.3.3 和 22.2.0。可轻松利用的漏洞允许未经身份验证的攻击者通过 HTTP 进行网络访问,从而破坏 Java SE 和 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可能导致未经授权即可造成 Oracle Java SE 和 Oracle GraalVM Enterprise Edition 部分拒绝服务(部分 DOS)。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞不适用于仅加载并运行可信代码(如管理员安装的代码)的 Java 部署,此部署通常存在于服务器上。(CVE-2022-21628)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM Enterprise Edition 产品中的漏洞(组件:Networking)。受影响的支持版本有 Oracle Java SE:11.0.16.1, 17.0.4.1, 19;
Oracle GraalVM Enterprise Edition:20.3.7、21.3.3 和 22.2.0。难以利用的漏洞允许未经身份验证的攻击者通过 HTTP 进行网络访问,从而破坏 Oracle Java SE 和 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可能导致在未经授权的情况下,即可访问并更新、插入或删除 Oracle Java SE 和 Oracle GraalVM Enterprise Edition 的部分可访问数据。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞不适用于仅加载并运行可信代码(如管理员安装的代码)的 Java 部署,此部署通常存在于服务器上。(CVE-2022-39399)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM Enterprise Edition 产品中的漏洞(组件:JSSE)。受影响的支持版本有 Oracle Java SE:11.0.17, 17.0.5, 19.0.1;
Oracle GraalVM Enterprise Edition:20.3.8、21.3.4 和 22.3.0。可轻松利用的漏洞允许未经身份验证的攻击者通过 DTLS 进行网络访问,从而破坏 Oracle Java SE 和 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可能导致未经授权即可造成 Oracle Java SE 和 Oracle GraalVM Enterprise Edition 部分拒绝服务(部分 DOS)。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞不适用于仅加载并运行可信代码(如管理员安装的代码)的 Java 部署,此部署通常存在于服务器上。(CVE-2023-21835)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM Enterprise Edition 产品中的漏洞(组件:Sound)。受影响的支持版本有 Oracle Java SE:8u351、8u351-perf、11.0.17、17.0.5、19.0.1;Oracle GraalVM Enterprise Edition:20.3.8、21.3.4 和 22.3.0。此漏洞较难受到攻击,其允许未经身份验证的攻击者通过多种协议进行网络访问,从而破坏 Oracle Java SE 和 Oracle GraalVM Enterprise Edition。成功攻击此漏洞可能导致在未经授权的情况下,即可访问并更新、插入或删除 Oracle Java SE 和 Oracle GraalVM Enterprise Edition 的部分可访问数据。注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞不适用于仅加载并运行可信代码(如管理员安装的代码)的 Java 部署,此部署通常存在于服务器上。(CVE-2023-21843)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级 openjdk-11 程序包。

对于 Debian 10 buster,已在 11.0.18+10-1~deb10u1 版本中修复这些问题。

另见

https://security-tracker.debian.org/tracker/source-package/openjdk-11

https://www.debian.org/lts/security/2023/dla-3307

https://security-tracker.debian.org/tracker/CVE-2022-21619

https://security-tracker.debian.org/tracker/CVE-2022-21624

https://security-tracker.debian.org/tracker/CVE-2022-21626

https://security-tracker.debian.org/tracker/CVE-2022-21628

https://security-tracker.debian.org/tracker/CVE-2022-39399

https://security-tracker.debian.org/tracker/CVE-2023-21835

https://security-tracker.debian.org/tracker/CVE-2023-21843

https://packages.debian.org/source/buster/openjdk-11

插件详情

严重性: Low

ID: 171041

文件名: debian_DLA-3307.nasl

版本: 1.1

类型: local

代理: unix

发布时间: 2023/2/6

最近更新时间: 2023/9/5

支持的传感器: Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

风险信息

VPR

风险因素: Low

分数: 2.2

CVSS v2

风险因素: Low

基本分数: 2.6

时间分数: 2.1

矢量: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

CVSS 分数来源: CVE-2023-21843

CVSS v3

风险因素: Low

基本分数: 3.7

时间分数: 3.5

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

时间矢量: CVSS:3.0/E:F/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:debian:debian_linux:openjdk-11-dbg, p-cpe:/a:debian:debian_linux:openjdk-11-demo, p-cpe:/a:debian:debian_linux:openjdk-11-doc, p-cpe:/a:debian:debian_linux:openjdk-11-jdk, p-cpe:/a:debian:debian_linux:openjdk-11-jdk-headless, p-cpe:/a:debian:debian_linux:openjdk-11-jre, p-cpe:/a:debian:debian_linux:openjdk-11-jre-headless, p-cpe:/a:debian:debian_linux:openjdk-11-jre-zero, p-cpe:/a:debian:debian_linux:openjdk-11-source, cpe:/o:debian:debian_linux:10.0

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2023/2/6

漏洞发布日期: 2022/10/17

参考资料信息

CVE: CVE-2022-21619, CVE-2022-21624, CVE-2022-21626, CVE-2022-21628, CVE-2022-39399, CVE-2023-21835, CVE-2023-21843