Splunk Enterprise 8.1 < 8.1.13、8.2.0 < 8.2.10、9.0.0 < 9.0.4 (SVD-2023-0206)

medium Nessus 插件 ID 171565

简介

远程 Web 服务器主机上运行的应用程序受到一个漏洞的影响

描述

远程主机上安装的 Splunk 版本低于测试版本。因此,该应用程序受到 SVD-2023-0206 公告中提及的漏洞的影响。

- 在低于 8.1.13、8.2.10 和 9.0.4 的 Splunk Enterprise 版本中,搜索中的“search_listener”参数允许经身份验证的用户进行服务器端盲目请求伪造 (SSRF)。如果环境中不存在其他漏洞,则请求发起方无法查看响应。(CVE-2023-22936)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

Splunk Enterprise 用户应升级到 8.1.13、8.2.10、9.0.4 或更高版本。
对于 Splunk Cloud Platform 版本,Splunk 会主动修补和监控 Splunk Cloud 实例。

另见

https://advisory.splunk.com/advisories/SVD-2023-0206.html

插件详情

严重性: Medium

ID: 171565

文件名: splunk_904_cve-2023-22936.nasl

版本: 1.4

类型: combined

代理: windows, macosx, unix

系列: CGI abuses

发布时间: 2023/2/16

最近更新时间: 2024/4/26

配置: 启用偏执模式

支持的传感器: Nessus Agent, Nessus

风险信息

VPR

风险因素: Low

分数: 3.4

CVSS v2

风险因素: Medium

基本分数: 6.5

时间分数: 4.8

矢量: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

CVSS 分数来源: CVE-2023-22936

CVSS v3

风险因素: Medium

基本分数: 6.3

时间分数: 5.5

矢量: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:splunk:splunk

必需的 KB 项: Settings/ParanoidReport, installed_sw/Splunk

易利用性: No known exploits are available

补丁发布日期: 2023/2/14

漏洞发布日期: 2023/2/14

参考资料信息

CVE: CVE-2023-22936

CWE: 918

IAVA: 2023-A-0101-S