Apache Tomcat 9.0.0.M1 < 9.0.72

medium Nessus 插件 ID 173251

简介

远程 Apache Tomcat 服务器受到一个漏洞的影响

描述

远程主机上安装的 Tomcat 版本低于 9.0.72。因此,它会受到公告 fixed_in_apache_tomcat_9.0.72_security-9 advisory 中提及的漏洞的影响。

- 将 RemoteIpFilter 用于通过 HTTP 从反向代理接收的请求(包含设置为 https 的 X-Forwarded-Proto 标头)时,由 Apache Tomcat 11.0.0-M1 至 11.0.0.-M2、10.1.0-M1 至 10.1.5、9.0.0-M1 至 9.0.71 以及 8.5.0 至 8.5.85 创建的会话 Cookie 不会包含 secure 属性。这可能导致用户代理通过不安全的通道传输会话 Cookie。(CVE-2023-28708)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级到 Apache Tomcat 9.0.72 版本或更高版本。

另见

http://www.nessus.org/u?f8ac9d8a

https://bz.apache.org/bugzilla/show_bug.cgi?id=66471

http://www.nessus.org/u?fa600361

插件详情

严重性: Medium

ID: 173251

文件名: tomcat_9_0_72.nasl

版本: 1.4

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2023/3/22

最近更新时间: 2024/5/6

支持的传感器: Nessus Agent, Nessus

风险信息

VPR

风险因素: Low

分数: 1.4

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

CVSS 分数来源: CVE-2023-28708

CVSS v3

风险因素: Medium

基本分数: 4.3

时间分数: 3.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:apache:tomcat:9

必需的 KB 项: installed_sw/Apache Tomcat

易利用性: No known exploits are available

漏洞发布日期: 2023/3/22

参考资料信息

CVE: CVE-2023-28708

IAVA: 2023-A-0156-S