Ubuntu 20.04 LTS/22.04 LTS/23.04:libssh 漏洞 (USN-6138-1)

medium Nessus 插件 ID 176712

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 20.04 LTS / 22.04 LTS / 22.10 / 23.04 主机上安装的程序包受到 USN-6138-1 公告中提及的多个漏洞的影响。

- 在更新密钥期间通过算法猜测在 libssh 中造成空指针取消引用。此问题可能允许经身份验证的客户端造成拒绝服务。(CVE-2023-1667)

- 在 libssh 中发现因内存分配问题产生的漏洞,导致可以通过 `pki_verify_data_signature` 函数对连接的客户端绕过认证检查。如果内存不足或内存使用量有限,则可能发生此问题。此问题由返回值 `rc` 引起,该值被初始化为 SSH_ERROR 并在之后被重写以保存函数调用 `pki_key_check_hash_compatible` 的返回值。变量的值在此点验证和加密验证之间不会发生改变。因此,它们之间的任何错误都会调用返回 SSH_OK 的 `goto error`。
(CVE-2023-2283)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的程序包。

另见

https://ubuntu.com/security/notices/USN-6138-1

插件详情

严重性: Medium

ID: 176712

文件名: ubuntu_USN-6138-1.nasl

版本: 1.5

类型: local

代理: unix

发布时间: 2023/6/5

最近更新时间: 2023/12/22

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 6.4

时间分数: 5

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:N

CVSS 分数来源: CVE-2023-2283

CVSS v3

风险因素: Medium

基本分数: 6.5

时间分数: 5.9

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, cpe:/o:canonical:ubuntu_linux:23.04, p-cpe:/a:canonical:ubuntu_linux:libssh-4, p-cpe:/a:canonical:ubuntu_linux:libssh-dev, p-cpe:/a:canonical:ubuntu_linux:libssh-gcrypt-4, p-cpe:/a:canonical:ubuntu_linux:libssh-gcrypt-dev

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2023/6/5

漏洞发布日期: 2023/5/11

参考资料信息

CVE: CVE-2023-1667, CVE-2023-2283

IAVA: 2023-A-0517-S

USN: 6138-1