GLSA-202309-08 : Requests:信息泄露

medium Nessus 插件 ID 181512

语言:

描述

远程主机受到 GLSA-202309-08 中所述漏洞的影响(请求:信息泄露)

- Requests 是一个 HTTP 库。自 Requests 2.3.0 起,当重定向到 HTTPS 端点时,Requests 会一直向目标服务器泄露 Proxy-Authorization 标头。这是我们使用 `rebuild_proxies` 向请求重新附加 `Proxy-Authorization` 标头的结果。对于通过隧道发送的 HTTP 连接,代理将识别请求本身的标头并将其删除,然后再转发到目标服务器。但是,当通过 HTTPS 发送时,由于代理无法查看隧道请求,因而必须在 CONNECT 请求中发送 `Proxy-Authorization` 标头。这会导致 Requests 意外将代理凭据转发到目标服务器,从而允许恶意攻击者泄露敏感信息。已在版本 2.31.0 中修补此问题。
(CVE-2023-32681)

请注意,Nessus 尚未测试此问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

所有 Requests 用户皆应升级到最新版本:

# emerge --sync # emerge --ask --oneshot --verbose >=dev-python/requests-2.31.0

另见

https://security.gentoo.org/glsa/202309-08

https://bugs.gentoo.org/show_bug.cgi?id=906970

插件详情

严重性: Medium

ID: 181512

文件名: gentoo_GLSA-202309-08.nasl

版本: 1.2

类型: local

发布时间: 2023/9/17

最近更新时间: 2023/9/21

支持的传感器: Nessus

风险信息

VPR

风险因素: Medium

分数: 5.2

CVSS v2

风险因素: Medium

基本分数: 5.4

时间分数: 4.2

矢量: CVSS2#AV:N/AC:H/Au:N/C:C/I:N/A:N

CVSS 分数来源: CVE-2023-32681

CVSS v3

风险因素: Medium

基本分数: 6.1

时间分数: 5.5

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:gentoo:linux:requests, cpe:/o:gentoo:linux

必需的 KB 项: Host/local_checks_enabled, Host/Gentoo/release, Host/Gentoo/qpkg-list

可利用: true

易利用性: Exploits are available

补丁发布日期: 2023/9/17

漏洞发布日期: 2023/5/22

参考资料信息

CVE: CVE-2023-32681