Debian DSA-5523-1:curl - 安全更新

critical Nessus 插件 ID 182908

简介

远程 Debian 主机上缺少一个或多个与安全性相关的更新。

描述

远程 Debian 11/12 主机上安装的多个程序包受到 dsa-5523 公告中提及的多个漏洞影响。

- CVE-2023-38545 是 libcurl 和 curl 的 SOCKS5 代理握手中存在的基于堆的缓冲区溢出漏洞。当为 curl 提供一个主机名以传递给长度大于 255 字节的 SOCKS5 代理时,它将切换到本地名称解析,以便在将其传递给 SOCKS5 代理之前解析该地址。但由于 2020 年引入的错误,此本地名称解析可能会因 SOCKS5 握手缓慢而失败,导致 curl 将长度大于 255 字节的主机名传递到目标缓冲区,从而导致堆溢出情形。 CVE-2023-38545 的公告中提供了重定向到特制 URL 的恶意 HTTPS 服务器的示例利用情况。虽然攻击者似乎需要影响 SOCKS5 握手的缓慢程度,但该公告指出,服务器延迟可能足够缓慢,足以触发此错误。(CVE-2023-38545)

- CVE-2023-38546 是 curl_easy_duphandle() 中的 Cookie 注入漏洞,而 curl_easy_duphandle() 是 libcurl 中复制简单句柄的函数。复制简单句柄时,如果启用了 Cookie,则复制的简单句柄将不会复制 Cookie 本身,而会将文件名设置为 none'。因此,在随后使用重复的简单句柄时,如果没有为 Cookie 设置源,libcurl 就会尝试从磁盘上名为 none' 的文件加载它们。该漏洞的评级为“低危”,因为利用该漏洞所需的各种条件不太可能出现。(CVE-2023-38546)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级 curl 程序包。

对于稳定发行版本 (bookworm),已在版本 7.88.1-10+deb12u4 中修复这些问题。

另见

https://security-tracker.debian.org/tracker/source-package/curl

https://www.debian.org/security/2023/dsa-5523

https://security-tracker.debian.org/tracker/CVE-2023-38545

https://security-tracker.debian.org/tracker/CVE-2023-38546

https://packages.debian.org/source/bullseye/curl

https://packages.debian.org/source/bookworm/curl

插件详情

严重性: Critical

ID: 182908

文件名: debian_DSA-5523.nasl

版本: 1.5

类型: local

代理: unix

发布时间: 2023/10/11

最近更新时间: 2023/12/8

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

风险信息

VPR

风险因素: High

分数: 7.4

CVSS v2

风险因素: Critical

基本分数: 10

时间分数: 7.8

矢量: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS 分数来源: CVE-2023-38545

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.8

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: cpe:/o:debian:debian_linux:11.0, p-cpe:/a:debian:debian_linux:libcurl4, p-cpe:/a:debian:debian_linux:curl, cpe:/o:debian:debian_linux:12.0, p-cpe:/a:debian:debian_linux:libcurl3-nss, p-cpe:/a:debian:debian_linux:libcurl4-gnutls-dev, p-cpe:/a:debian:debian_linux:libcurl4-doc, p-cpe:/a:debian:debian_linux:libcurl3-gnutls, p-cpe:/a:debian:debian_linux:libcurl4-nss-dev, p-cpe:/a:debian:debian_linux:libcurl4-openssl-dev

必需的 KB 项: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2023/10/11

漏洞发布日期: 2023/10/11

参考资料信息

CVE: CVE-2023-38545, CVE-2023-38546

IAVA: 2023-A-0531-S