RHEL 8:内核 (RHSA-2024: 0930)

high Nessus 插件 ID 190828

简介

远程 Red Hat 主机缺少一个或多个内核安全更新。

描述

远程 Redhat Enterprise Linux 8 主机上安装的程序包受到 RHSA-2024: 0930 公告中提及的多个漏洞的影响。

- 通过 ioctl cmd FBIOPUT_VSCREENINFO 向内核发送恶意数据时,内核将越界写入内存。(CVE-2021-33655)

- 产品:Android 版本:Android 内核 Android ID:A-224546354References: 上游内核 (CVE-2022-20368)

- KVM:VMX 内的 Linux 内核中存在回归漏洞,允许发起推测执行攻击。
在 KVM (L0) 宣称会向 L1 提供 eIBRS 支持的背景下, L1 认为在运行 L2 之后便不需要使用 retpoline 或 IBPB,导致 L2 可以对 L1 执行 Spectre v2 攻击。在 L2 上拥有代码执行权的攻击者可以在主机的间接分支上执行代码。我们建议升级到内核 6.2 或过去的提交 2e7eab81425a (CVE-2022-2196)

- 2022 年 3 月 8 日之前发布的某些 Arm Cortex 和 Neoverse 处理器无法正确限制缓存推测,即 Spectre-BHB。攻击者可利用分支历史记录缓冲区 (BHB) 中的共享分支历史记录来影响预测错误的分支。之后,攻击者便可通过缓存分配来获取敏感信息。(CVE-2022-23960)

- Linux 内核 net/sched 中的不当更新引用计数漏洞允许本地攻击者将权限升级到根层级。此问题影响以下版本:Linux 内核 5.18 之前版本;4.14 和更新版本。(CVE-2022-29581)

- 在用户针对基于 Empia 28xx 的电视卡触发 em28xx_usb_probe() 的方式中,发现 Linux 内核 video4linux 驱动程序中存在释放后使用缺陷。本地攻击者可利用此缺陷造成系统崩溃,或可能提升其在系统中的权限。(CVE-2022-3239)

- 在 Linux 内核中发现一个漏洞。已将此漏洞归类为“危急”。这会影响组件 IPsec 的文件 net/core/devlink.c 的函数 devlink_param_set/devlink_param_get。操纵此漏洞可导致释放后使用。建议应用补丁修复此问题。此漏洞获派的标识符为 VDB-211929。(CVE-2022-3625)

- 在采用设备文件“/dev/dri/renderD128(或 Dxxx)”的 Linux 内核中,在 GPU 组件的 drivers/gpu/vmxgfx/vmxgfx_execbuf.c 中的 vmwgfx 驱动程序中发现整数溢出漏洞。在系统中具有用户帐户的本地攻击者可利用此缺陷获得特权,造成拒绝服务 (DoS)。
(CVE-2022-36402)

- 在采用设备文件“/dev/dri/renderD128(或 Dxxx)”的 Linux 内核中,在 GPU 组件的 drivers/gpu/vmxgfx/vmxgfx_execbuf.c 中的 vmwgfx 驱动程序中发现空指针取消引用漏洞。在系统中具有用户帐户的本地攻击者可利用此缺陷获得特权,造成拒绝服务 (DoS)。
(CVE-2022-38096)

- 在 Linux 内核的 vmwgfx 驱动程序的设备文件“/dev/dri/renderD128(或 Dxxx)”中,在 drivers/gpu/vmxgfx/vmxgfx_execbuf.c 的函数“vmw_cmd_res_check”中发现了释放后使用 (UAF) 漏洞。在系统中具有用户帐户的本地攻击者可利用此缺陷获得特权,造成拒绝服务 (DoS)。CVE-2022-38457

- 在 Linux 内核的 vmwgfx 驱动程序的设备文件“/dev/dri/renderD128(或 Dxxx)”中,在 drivers/gpu/vmxgfx/vmxgfx_execbuf.c 的函数“vmw_execbuf_tie_context”中发现了释放后使用 (UAF) 漏洞。在系统中具有用户帐户的本地攻击者可利用此缺陷获得特权,造成拒绝服务 (DoS)。CVE-2022-40133

- 在 Linux 内核的流控制传输协议中发现内存泄漏缺陷。当用户启动恶意网络服务而有人连接到此服务时,可能会发生此问题。本地用户可利用此缺陷来耗尽资源,从而造成拒绝服务。(CVE-2023-1074)

- 在 6.2.8 及之前版本的 Linux 内核的 arch/x86/kvm/vmx/nested.c 中发现一个问题。x86_64 上的 nVMX 缺少对 CR0 和 CR4 的一致性检查。(CVE-2023-30456)

- 在 Linux 内核 6.2 的 drivers/media/dvb-core/dvb_frontend.c 中发现一个问题。当任务处于 !TASK_RUNNING 状态时,会发生阻止操作。在 dvb_frontend_get_event 中,调用 wait_event_interruptible;条件为 dvb_frontend_test_event(fepriv,events)。在 dvb_frontend_test_event 中,调用 down(&fepriv->sem)。但是,wait_event_interruptible 会使进程进入休眠状态,而 down(&fepriv->sem) 可能会阻断进程。(CVE-2023-31084)

- 在 Linux 内核 6.4.12 之前的版本中,drivers/gpu/drm/amd/amdgpu/amdgpu_cs.c 中的 amdgpu_cs_wait_all_fences 存在释放后使用屏蔽。(CVE-2023-51042)

- 在 Linux 内核的 GSM 0710 tty 多路器中发现争用条件。之所以发生此问题,是因为两个线程在 gsm 行规则已启用的情况下对同一 tty 文件描述符执行了 GSMIOC_SETCONF ioctl,并且会在重新启动 gsm mux 时导致 struct gsm_dlci 发生释放后使用问题。本地非特权用户可利用此问题提升其在系统中的权限。(CVE-2023-6546)

- 可以利用 Linux 内核的性能事件系统组件中的堆越界写入漏洞实现本地特权提升。perf_event 的 read_size 可能溢出,导致 perf_read_group() 发生堆越界递增或写入。我们建议升级过去的提交 382c27f4ed28f803b1f1473ac2d8db0afc795a1b。(CVE-2023-6931)

- Linux 内核的 netfilter 中存在释放后使用漏洞:可利用 nf_tables 组件实现本地权限升级。nft_verdict_init() 函数允许在挂钩判定中将正值作为丢弃错误,因此,当 NF_DROP 发出类似于 NF_ACCEPT 的丢弃错误时,nf_hook_slow() 函数可造成双重释放漏洞。我们建议升级过去的提交 f342de4e2f33e0e39165d8639387aa6c19dff660。(CVE-2024-1086)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

更新 RHEL 内核程序包,依据 RHSA-2024: 0930 中的指引。

另见

http://www.nessus.org/u?c43384b9

https://access.redhat.com/security/updates/classification/#important

https://bugzilla.redhat.com/show_bug.cgi?id=2062284

https://bugzilla.redhat.com/show_bug.cgi?id=2088021

https://bugzilla.redhat.com/show_bug.cgi?id=2108691

https://bugzilla.redhat.com/show_bug.cgi?id=2123695

https://bugzilla.redhat.com/show_bug.cgi?id=2127985

https://bugzilla.redhat.com/show_bug.cgi?id=2133451

https://bugzilla.redhat.com/show_bug.cgi?id=2133452

https://bugzilla.redhat.com/show_bug.cgi?id=2133453

https://bugzilla.redhat.com/show_bug.cgi?id=2133455

https://bugzilla.redhat.com/show_bug.cgi?id=2144720

https://bugzilla.redhat.com/show_bug.cgi?id=2160023

https://bugzilla.redhat.com/show_bug.cgi?id=2173430

https://bugzilla.redhat.com/show_bug.cgi?id=2188468

https://bugzilla.redhat.com/show_bug.cgi?id=2213139

https://bugzilla.redhat.com/show_bug.cgi?id=2252731

https://bugzilla.redhat.com/show_bug.cgi?id=2255498

https://bugzilla.redhat.com/show_bug.cgi?id=2259866

https://bugzilla.redhat.com/show_bug.cgi?id=2262126

https://access.redhat.com/errata/RHSA-2024:0930

插件详情

严重性: High

ID: 190828

文件名: redhat-RHSA-2024-0930.nasl

版本: 1.3

类型: local

代理: unix

发布时间: 2024/2/21

最近更新时间: 2024/4/28

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

风险信息

VPR

风险因素: Critical

分数: 9.6

CVSS v2

风险因素: High

基本分数: 7.2

时间分数: 6.3

矢量: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS 分数来源: CVE-2022-29581

CVSS v3

风险因素: High

基本分数: 8.8

时间分数: 8.4

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:H/RL:O/RC:C

CVSS 分数来源: CVE-2022-2196

漏洞信息

CPE: p-cpe:/a:redhat:enterprise_linux:kernel-debug, p-cpe:/a:redhat:enterprise_linux:kernel-debug-devel, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-modules, p-cpe:/a:redhat:enterprise_linux:bpftool, p-cpe:/a:redhat:enterprise_linux:kernel-debug-modules, p-cpe:/a:redhat:enterprise_linux:kernel-modules, p-cpe:/a:redhat:enterprise_linux:kernel-tools, p-cpe:/a:redhat:enterprise_linux:kernel, cpe:/o:redhat:rhel_eus:8.6, p-cpe:/a:redhat:enterprise_linux:kernel-devel, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump, p-cpe:/a:redhat:enterprise_linux:python3-perf, cpe:/o:redhat:enterprise_linux:8, p-cpe:/a:redhat:enterprise_linux:kernel-debug-core, p-cpe:/a:redhat:enterprise_linux:perf, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs, p-cpe:/a:redhat:enterprise_linux:kernel-cross-headers, p-cpe:/a:redhat:enterprise_linux:kernel-modules-extra, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs-devel, p-cpe:/a:redhat:enterprise_linux:kernel-core, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-core, p-cpe:/a:redhat:enterprise_linux:kernel-debug-modules-extra, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-modules-extra, p-cpe:/a:redhat:enterprise_linux:kernel-zfcpdump-devel

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

可利用: true

易利用性: Exploits are available

补丁发布日期: 2024/2/21

漏洞发布日期: 2022/3/13

可利用的方式

Core Impact

参考资料信息

CVE: CVE-2021-33655, CVE-2022-20368, CVE-2022-2196, CVE-2022-23960, CVE-2022-29581, CVE-2022-3239, CVE-2022-3625, CVE-2022-36402, CVE-2022-38096, CVE-2022-38457, CVE-2022-40133, CVE-2023-1074, CVE-2023-30456, CVE-2023-31084, CVE-2023-51042, CVE-2023-6546, CVE-2023-6931, CVE-2024-1086

CWE: 1188, 190, 358, 401, 416, 476, 787

RHSA: 2024:0930