Ubuntu 20.04 LTS / 22.04 LTS / 23.10:Open vSwitch 漏洞 (USN-6690-1)

medium Nessus 插件 ID 191928

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 20.04 LTS / 22.04 LTS / 23.10 主机上安装的程序包受到 USN-6690-1 公告中提及的多个漏洞的影响。

- 在 Open vSwitch 中发现一个缺陷,其中的多个版本容易受到构建的 Geneve 数据包影响,可能导致拒绝服务和无效的内存访问。触发此问题需要启用通过 netlink 路径的硬件卸载。 (CVE-2023-3966)

- Open vSwitch 中发现了一个缺陷,该缺陷允许虚拟机之间的 ICMPv6 邻居通告数据包绕过 OpenFlow 规则。此问题可能允许本地攻击者创建带有修改或欺骗的目标 IP 地址字段的特制数据包,该数据包可以将 ICMPv6 流量重定向到任意 IP 地址。(CVE-2023-5366)

请注意,Nessus 尚未测试这些问题,而是只依靠应用程序自我报告的版本号来判断。

解决方案

更新受影响的程序包。

另见

https://ubuntu.com/security/notices/USN-6690-1

插件详情

严重性: Medium

ID: 191928

文件名: ubuntu_USN-6690-1.nasl

版本: 1.0

类型: local

代理: unix

发布时间: 2024/3/12

最近更新时间: 2024/3/12

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

风险信息

VPR

风险因素: Low

分数: 3.6

CVSS v2

风险因素: Medium

基本分数: 4.6

时间分数: 3.4

矢量: CVSS2#AV:L/AC:L/Au:S/C:N/I:C/A:N

CVSS 分数来源: CVE-2023-5366

CVSS v3

风险因素: Medium

基本分数: 5.5

时间分数: 4.8

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:20.04:-:lts, cpe:/o:canonical:ubuntu_linux:22.04:-:lts, cpe:/o:canonical:ubuntu_linux:23.10, p-cpe:/a:canonical:ubuntu_linux:openvswitch-common, p-cpe:/a:canonical:ubuntu_linux:openvswitch-ipsec, p-cpe:/a:canonical:ubuntu_linux:openvswitch-pki, p-cpe:/a:canonical:ubuntu_linux:openvswitch-source, p-cpe:/a:canonical:ubuntu_linux:openvswitch-switch, p-cpe:/a:canonical:ubuntu_linux:openvswitch-switch-dpdk, p-cpe:/a:canonical:ubuntu_linux:openvswitch-test, p-cpe:/a:canonical:ubuntu_linux:openvswitch-testcontroller, p-cpe:/a:canonical:ubuntu_linux:openvswitch-vtep, p-cpe:/a:canonical:ubuntu_linux:python3-openvswitch

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2024/3/12

漏洞发布日期: 2023/10/6

参考资料信息

CVE: CVE-2023-3966, CVE-2023-5366

USN: 6690-1