Ubuntu 18.04 LTS / 20.04 LTS / 22.04 LTS / 23.10 : OpenJDK 8 漏洞 (USN-6696-1)

high Nessus 插件 ID 192188

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 18.04 LTS / 20.04 LTS / 22.04 LTS / 23.10 主机上安装的程序包受到 USN-6696-1 公告中提及的多个漏洞的影响。

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 产品中存在漏洞(组件:Hotspot)。支持的版本中受影响的是 Oracle Java SE:8u391、8u391-perf、11.0.21、17.0.9、21.0.1;Oracle GraalVM for JDK:17.0.9、21.0.1;Oracle GraalVM Enterprise Edition:20.3.12、21.3.8 和 22.3.4。攻击此漏洞的难度较大,通过多种协议访问网络的未经身份验证的攻击者可以利用此漏洞破坏 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition。成功利用此漏洞进行攻击可导致在未经授权的情况下创建、删除或修改关键数据或所有 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 可访问数据的访问权限,以及未经授权即可访问关键数据或完整访问所有 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Editio 可访问数据。
注意:此漏洞可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。此漏洞也适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。
(CVE-2024-20918)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 产品中存在漏洞(组件:Hotspot)。支持的版本中受影响的是 Oracle Java SE:8u391、8u391-perf、11.0.21、17.0.9、21.0.1;Oracle GraalVM for JDK:17.0.9、21.0.1;Oracle GraalVM Enterprise Edition:20.3.12、21.3.8 和 22.3.4。攻击此漏洞的难度较大,通过多种协议访问网络的未经身份验证的攻击者可以利用此漏洞破坏 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition。成功攻击此漏洞可导致在未经授权的情况下创建、删除或修改重要数据或 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 可访问的所有数据。注意:此漏洞只能通过向指定组件中的 API 提供数据而遭到利用,不使用不可信的 Java Web Start 应用程序或不可信的 Java 小程序,例如通过 Web 服务。(CVE-2024-20919)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 产品中存在漏洞(组件:Hotspot)。支持的版本中受影响的是 Oracle Java SE:8u391、8u391-perf、11.0.21、17.0.9、21.0.1;Oracle GraalVM for JDK:17.0.9、21.0.1;Oracle GraalVM Enterprise Edition:20.3.12、21.3.8 和 22.3.4。攻击此漏洞的难度较大,通过多种协议访问网络的未经身份验证的攻击者可以利用此漏洞破坏 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition。如果攻击成功,攻击者可在未经授权的情况下访问重要数据,或完整访问 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 的所有可访问数据。注意:此漏洞可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。此漏洞也适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。(CVE-2024-20921)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 产品中存在漏洞(组件:Scripting)。支持的版本中受影响的是 Oracle Java SE:8u391、8u391-perf、11.0.21;Oracle GraalVM for JDK:17.0.9;Oracle GraalVM Enterprise Edition:20.3.12、21.3.8 和 22.3.4。攻击此漏洞的难度较大,通过多种协议访问网络的未经身份验证的攻击者可以利用此漏洞破坏 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition。如果攻击成功,攻击者可在未经授权的情况下访问重要数据,或完整访问 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 的所有可访问数据。注意:此漏洞可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。此漏洞也适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。(CVE-2024-20926)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 产品中存在漏洞(组件:Security)。支持的版本中受影响的是 Oracle Java SE:8u391、8u391-perf、11.0.21、17.0.9、21.0.1;Oracle GraalVM for JDK:17.0.9、21.0.1;Oracle GraalVM Enterprise Edition:20.3.12、21.3.8 和 22.3.4。此漏洞较难利用,可登录执行 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 所在基础架构的低权限攻击者可利用此漏洞,破坏 Oracle Java SE、Oracle GraalVM for JDK 和 Oracle GraalVM Enterprise Edition。
如果攻击成功,攻击者可在未经授权的情况下访问重要数据,或完整访问 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 的所有可访问数据。
注意:此漏洞可通过使用指定组件中的 API 加以利用,如通过向 API 提供数据的 Web 服务。此漏洞也适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。
(CVE-2024-20945)

- Oracle Java SE 的 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 产品中存在漏洞(组件:Security)。支持的版本中受影响的是 Oracle Java SE:8u391、8u391-perf、11.0.21、17.0.9、21.0.1;Oracle GraalVM for JDK:17.0.9、21.0.1;Oracle GraalVM Enterprise Edition:20.3.12、21.3.8 和 22.3.4。攻击此漏洞的难度较大,通过多种协议访问网络的未经身份验证的攻击者可以利用此漏洞破坏 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition。成功利用此漏洞进行攻击可导致在未经授权的情况下创建、删除或修改关键数据或所有 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 可访问数据的访问权限,以及未经授权即可访问关键数据或完整访问所有 Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Editio 可访问数据。
注意:此漏洞适用于需加载并运行不可信代码(如来自互联网的代码)且安全性依赖于 Java 沙盒的 Java 部署,该部署通常在需在沙盒中运行 Java Web Start 应用程序或需在沙盒中运行 Java 小程序的客户端上。此漏洞不适用于仅加载并运行可信代码(如管理员安装的代码)的 Java 部署,此部署通常存在于服务器上。(CVE-2024-20952)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的程序包。

另见

https://ubuntu.com/security/notices/USN-6696-1

插件详情

严重性: High

ID: 192188

文件名: ubuntu_USN-6696-1.nasl

版本: 1.1

类型: local

代理: unix

发布时间: 2024/3/18

最近更新时间: 2024/3/18

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 6.0

CVSS v2

风险因素: High

基本分数: 7.1

时间分数: 5.3

矢量: CVSS2#AV:N/AC:H/Au:N/C:C/I:C/A:N

CVSS 分数来源: CVE-2024-20952

CVSS v3

风险因素: High

基本分数: 7.4

时间分数: 6.4

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/o:canonical:ubuntu_linux:22.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jre, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-source, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jdk-headless, cpe:/o:canonical:ubuntu_linux:18.04:-:lts, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-demo, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jdk, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jre-headless, p-cpe:/a:canonical:ubuntu_linux:openjdk-8-jre-zero, cpe:/o:canonical:ubuntu_linux:23.10, cpe:/o:canonical:ubuntu_linux:20.04:-:lts

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

易利用性: No known exploits are available

补丁发布日期: 2024/3/18

漏洞发布日期: 2024/1/16

参考资料信息

CVE: CVE-2024-20918, CVE-2024-20919, CVE-2024-20921, CVE-2024-20926, CVE-2024-20945, CVE-2024-20952

USN: 6696-1