AlmaLinux 9.2 [TuxCare] 安全更新:openssl / openssl-devel / openssl-libs / openssl-perl 多个漏洞 (ALMALINUX9.2:CLSA-2026:1782976762)

medium Nessus 插件 ID 362281

简介

AlmaLinux 主机缺少一个或多个安全更新。

描述

AlmaLinux 9.2 主机上存在安装的程序包,该程序包受到 TuxCare ALMALINUX9.2:CLSA-2026:2026:1782976762公告中提及的多个漏洞的影响。

- 问题摘要:AES-SIV (RFC 5297) 和 AES-GCM-SIV (RFC 8452) 的实现使用空密文错误地处理 AAD(附加认证数据)的认证,从而允许伪造此类消息。影响汇总:攻击者可以使用任意 AAD 伪造空消息,使用这些密码发送给受害者的应用程序。AES-SIV (RFC 5297) 和 AES-GCM-SIV (RFC 8452) 是防随机数误用的 AEAD 模式:它们接受密钥、随机数、可选 AAD(经认证但未加密的字节)和纯文本,并生成密文和 16 字节标签。解密时,系统会记录“EVP_DecryptFinal_ex()”,仅当成功验证标签时才会返回成功。在这些密码的 OpenSSL 供应商实现中,只有在使用非空数据调用解密函数时,才会计算预期的标签。如果调用程序提供 AAD,然后调用“EVP_DecryptFinal_ex()”而未调用密文更新(收到的密文长度为零时可能发生此情况),则永远不会重新计算标签,并且仍保留其全零值。使用 AES-GCM-SIV 时,发送任意 AAD、空密文和全零标签的攻击者会以单次方式通过任何未知密钥的认证。使用 AES-SIV 时,为了发起攻击,应用程序必须在不重置密钥的情况下重用解密上下文。AES-SIV 是自 OpenSSL 3.0 开始实现的。AES-GCM-SIV 是自 OpenSSL 3.2 开始实现的。OpenSSL 本身 (TLS/CMS/PKCS7/HPKE/QUIC) 中实现的协议均不支持 AES-GCM-SIV 或 AES-SIV。要挂载攻击,应用程序必须实现自己的协议并使用 EVP 接口。此外,当具有空密文的消息到达时,它们必须跳过密文更新。4.0、3.6、3.5、3.4 和 3.0 中的 FIPS 模块不受此问题的影响,因为这些算法未经 FIPS 批准且受影响的代码位于 OpenSSL FIPS 模块边界之外。(CVE-2026-45446)

- 问题摘要:当 CMS 基于密码的解密(RFC 3211 / PWRI 密钥解包)处理攻击者提供的 CMS 数据时,攻击者选择的流模式 KEK 密码可在 kek_unwrap_key() 中触发堆越界读取。影响汇总:堆缓冲区过度读取可触发崩溃,如果输入缓冲区以内存页面边界结束,且后续页面未映射,则可能导致应用程序拒绝服务。不会泄露信息,因为过度读取字节不会泄露给攻击者。密钥解包功能执行 RFC 中指定的检查字节测试,该测试从基于消息中封装的密钥长度的堆分配中读取 7 字节。存在基于封装密码的块长度的最小长度检查。但是,该密码是从攻击者的 PWRI keyEncryptionAlgorithm 中携带的 OID 中选择的,且不要求该密码是块密码。当攻击者选择流模式密码时,防护措施将失效,且含有解包密钥的分配缓冲区可能太小,无法符合 RFC 中指定的检查字节,因此可能会发生缓冲区过度读取。调用不受信任的 CMS 数据中的 CMS_decrypt() 或 CMS_decrypt_set1_password() 的应用程序(等同于 openssl cms
-解密 -pwri_password ...)容易受到此问题的影响。无需密码知识:在任何认证成功之前,都会在尝试解包期间发生越界读取。越界读取受限于几个字节,并且不会写入输出,因此不会泄露信息。
触发崩溃需要向边界未映射内存进行分配,而普通分配器不太可能出现此情况。FIPS 模块不受此问题影响。(CVE-2026-9076)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

根据 TuxCare 公告 ALMALINUX9.2:CLSA-2026:1782976762 中的指南更新受影响的程序包。

另见

https://cve.tuxcare.com/els/releases/CLSA-2026:1782976762

http://www.nessus.org/u?a39a7ede

插件详情

严重性: Medium

ID: 362281

文件名: tuxcare_alma_linux_9.2_CLSA-2026-1782976762.nasl

版本: 1.1

类型: Local

发布时间: 2026/10/1

最近更新时间: 2026/10/1

支持的传感器: Continuous Assessment, Nessus Agent, Tenable Cloud Security, Tenable Self-Hosted Container Security, Nessus

风险信息

VPR

风险因素: Medium

分数: 5

百分位: 93.74

Vendor

Vendor Severity: Moderate

CVSS v2

风险因素: Medium

基本分数: 5

时间分数: 3.7

矢量: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:N

CVSS 分数来源: CVE-2026-45446

CVSS v3

风险因素: Medium

基本分数: 4.8

时间分数: 4.2

矢量: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

必需的 KB 项: Host/OS/extended-third-party, Host/local_checks_enabled, Host/AlmaLinux/release, Host/AlmaLinux/rpm-list, Host/cpu

易利用性: No known exploits are available

补丁发布日期: 2026/7/2

漏洞发布日期: 2026/6/9

参考资料信息

CVE: CVE-2026-45446, CVE-2026-9076

CLSA: 2026:1782976762