OpenSSL 0.9.8 < 0.9.8s 多个漏洞

critical Nessus 插件 ID 57459

简介

远程服务受到多个漏洞的影响。

描述

远程主机上安装的 OpenSSL 版本低于 0.9.8s。因此,它受到公告 0.9.8s 中提及的多个漏洞影响。

- 在 0.9.8s 之前的 OpenSSL、1.0.0e 之前的 OpenSSL 1.0.0、1.0.1n 之前的 OpenSSL 1.0.1 以及 1.0.2b 之前的 OpenSSL 1.0.2 中,crypto/bn/bn_gf2m.c 中的 BN_GF2m_mod_inv 函数无法正确处理其中曲线超出不规范二进制多项式字段的 ECParameters 结构,这允许远程攻击者通过使用椭圆曲线算法的会话造成拒绝服务(无限循环),这一点已由支持客户端认证的服务器所遭受的攻击证实。(CVE-2015-1788)

- 在 0.9.8s 之前以及 1.0.0f 之前的 1.x 的 OpenSSL 版本中,服务器网关加密 (SGC) 实现未正确处理握手重启,从而允许远程攻击者通过不明矢量造成拒绝服务(CPU 消耗)。(CVE-2011-4619)

- 在 0.9.8s 之前以及 1.0.0f 之前的 1.x 的 OpenSSL 版本中,如果启用了 RFC 3779 支持,允许远程攻击者通过 X.509 证书(包含与 (1) IP 地址块或 (2) 自制系统 (AS) 标识符相关的证书扩展数据)造成拒绝服务(断言失败)。(CVE-2011-4577)

- 0.9.8s 版之前的 OpenSSL 和 1.0.0f 版之前的 OpenSSL 1.x 中的 SSL 3.0 实现无法正确初始化块密码填充的数据结构,这可能允许远程攻击者通过解密 SSL 对等机发送的填充数据来获得敏感信息。(CVE-2011-4576)

- 当启用 X509_V_FLAG_POLICY_CHECK 时,0.9.8s 版之前的 OpenSSL 0.9.8 中的双重释放漏洞允许远程攻击者通过触发策略检查失败来产生不明影响。(CVE-2011-4109)

- 0.9.8s 版之前的 OpenSSL 和 1.0.0f 版之前的 OpenSSL 1.x 中的 DTLS 实现仅在特定填充有效的情况下执行 MAC 检查,这使远程攻击者更容易通过 padding oracle 攻击恢复明文。(CVE-2011-4108)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

升级到 OpenSSL 版本 0.9.8s 或更高版本。

另见

https://www.openssl.org/news/secadv/20120104.txt

https://www.openssl.org/news/secadv/20150611.txt

https://www.cve.org/CVERecord?id=CVE-2011-4108

https://www.cve.org/CVERecord?id=CVE-2011-4109

https://www.cve.org/CVERecord?id=CVE-2011-4576

https://www.cve.org/CVERecord?id=CVE-2011-4577

https://www.cve.org/CVERecord?id=CVE-2011-4619

https://www.cve.org/CVERecord?id=CVE-2015-1788

插件详情

严重性: Critical

ID: 57459

文件名: openssl_0_9_8s.nasl

版本: 1.17

类型: combined

代理: windows, macosx, unix

系列: Web Servers

发布时间: 2012/1/9

最近更新时间: 2024/6/7

支持的传感器: Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 5.9

CVSS v2

风险因素: High

基本分数: 9.3

时间分数: 6.9

矢量: CVSS2#AV:N/AC:M/Au:N/C:C/I:C/A:C

CVSS 分数来源: CVE-2011-4109

CVSS v3

风险因素: Critical

基本分数: 9.8

时间分数: 8.5

矢量: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:U/RL:O/RC:C

漏洞信息

CPE: cpe:/a:openssl:openssl

必需的 KB 项: installed_sw/OpenSSL

易利用性: No known exploits are available

补丁发布日期: 2012/1/4

漏洞发布日期: 2012/1/4

参考资料信息

CVE: CVE-2011-4108, CVE-2011-4109, CVE-2011-4576, CVE-2011-4577, CVE-2011-4619, CVE-2015-1788

BID: 51281, 47888

CERT: 536044