Oracle Linux 3 / 4 / 5:curl (ELSA-2009-1209)

high Nessus 插件 ID 67910

简介

远程 Oracle Linux 主机缺少一个或多个安全更新。

描述

来自 Red Hat 安全公告 2009:1209:

更新后的 curl 程序包修复了安全问题,现在可用于 Red Hat Enterprise Linux 3、4 和 5。

Red Hat 安全响应团队将此更新评级为具有中等安全影响。

cURL 是用于从 FTP、HTTP、Gopher、Telnet 和 DICT 服务器中获取文件的工具,该工具使用任何受支持的协议。 cURL 旨在无需用户交互或任何类型的互动便可进行工作。

Scott Cantor 报告称,cURL 受到之前发布的“null 前缀攻击”的影响,后者是由对 X.509 证书中的空字符的不当处理导致的。如果攻击者能获得由受信任的证书颁发机构签名的、精心构建的证书,则攻击者可在中间人攻击期间利用此证书,并可能使 cURL 混淆而错误地接受此证书。(CVE-2009-2417)

cURL 用户应升级这些更新后的程序包,其中包含用于修正这些问题的向后移植的修补程序。必须重新启动所有正在运行的使用 libcurl 的应用程序才能使更新生效。

解决方案

更新受影响的 curl 程序包。

另见

https://oss.oracle.com/pipermail/el-errata/2009-August/001114.html

https://oss.oracle.com/pipermail/el-errata/2009-August/001116.html

https://oss.oracle.com/pipermail/el-errata/2009-August/001117.html

插件详情

严重性: High

ID: 67910

文件名: oraclelinux_ELSA-2009-1209.nasl

版本: 1.8

类型: local

代理: unix

发布时间: 2013/7/12

最近更新时间: 2021/1/14

支持的传感器: Frictionless Assessment Agent, Nessus Agent, Nessus

风险信息

VPR

风险因素: Medium

分数: 5.5

CVSS v2

风险因素: High

基本分数: 7.5

时间分数: 6.2

矢量: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

漏洞信息

CPE: p-cpe:/a:oracle:linux:curl, p-cpe:/a:oracle:linux:curl-devel, cpe:/o:oracle:linux:3, cpe:/o:oracle:linux:4, cpe:/o:oracle:linux:5

必需的 KB 项: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/OracleLinux

可利用: true

易利用性: Exploits are available

补丁发布日期: 2009/8/13

漏洞发布日期: 2009/8/14

参考资料信息

CVE: CVE-2009-2417

BID: 36032

CWE: 310

RHSA: 2009:1209