Ubuntu 14.04 LTS:Linux 内核漏洞 (USN-2446-1)

high Nessus 插件 ID 80032

简介

远程 Ubuntu 主机缺少一个或多个安全更新。

描述

远程 Ubuntu 14.04 LTS 主机上安装的一个程序包受到 USN-2446-1 公告中提及的多个漏洞影响。

- 在 3.17.2 及之前的 Linux 内核中,SCTP 实现允许远程攻击者通过畸形 ASCONF 区块造成拒绝服务(系统崩溃),此问题与 net/sctp/sm_make_chunk.c 和 net/sctp/sm_statefuns.c 有关。(CVE-2014-3673)

- 在 3.17.2 及之前的 Linux 内核中, SCTP 实现的 net/sctp/associola.c 中的 sctp_assoc_lookup_asconf_ack 函数允许远程攻击者通过可触发副作用解释器中的错误泄漏的重复 ASCONF 区块造成拒绝服务(错误)。(CVE-2014-3687)

- 在 3.17.4 之前的 Linux 内核中的 SCTP 实现允许远程攻击者通过触发关联输出队列中与 net/sctp/inqueue.c 和 net/sctp/sm_statefuns.c 相关的大量区块造成拒绝服务(内存消耗),如 ASCONF 探测所证实。(CVE-2014-3688)

- 在 3.17.2 及之前的 Linux 内核中,kernel/trace/trace_syscalls.c 在使用 perf 子系统期间未正确处理私有 syscall 编号,从而允许本地用户通过构建的应用程序来造成拒绝服务(越界读取和 OOPS)或者绕过 ASLR 保护机制。(CVE-2014-7825)

- 在 3.17.2 及之前的 Linux 内核中,kernel/trace/trace_syscalls.c 在使用 ftrace 子系统期间未正确处理私有 syscall 编号,从而允许本地用户通过构建的应用程序来获取权限或造成拒绝服务(无效的指针取消引用)。(CVE-2014-7826)

- 在 3.18 及之前的 Linux 内核中,arch/x86/kernel/kvm.c 中的 paravirt_ops_setup 函数对 KVM 客户机内核使用的 paravirt_enabled 设置不当,这使客户机操作系统用户更容易通过构建能够读取 16 位值的应用程序绕过 ASLR 保护机制。(CVE-2014-8134)

- 在 3.17.2 及之前的 Linux 内核中,virt/kvm/iommu.c 中的 kvm_iommu_map_pages 函数在处理映射失败期间会误算页面数,从而允许客户机操作系统用户通过利用客户机操作系统权限来造成拒绝服务(主机操作系统页面解锁)或者可能造成其他不明影响。注意:此漏洞是由于对 CVE-2014-3601 的修复不正确导致的。(CVE-2014-8369)

- 在 3.17.4 及之前的 Linux 内核中,arch/x86/kernel/traps.c 中的 do_double_fault 函数未正确处理与堆栈段 (SS) 段寄存器相关的错误,从而允许本地用户通过 modify_ldt 系统调用造成拒绝服务(错误),这一点已由 linux-clock-tests 测试套件中的 sigreturn_32 证实。(CVE-2014-9090)

- 在 3.17.5 之前的 Linux 内核中,arch/x86/kernel/entry_64.S 未正确处理与堆栈段 (SS) 寄存器关联的错误,从而允许本地用户通过触发 IRET 指令(该指令导致访问错误空间中的 GS 基址)获取权限。(CVE-2014-9322)

请注意,Nessus 尚未测试这些问题,而是只依据应用程序自我报告的版本号进行判断。

解决方案

更新受影响的 kernel 程序包。

另见

https://ubuntu.com/security/notices/USN-2446-1

插件详情

严重性: High

ID: 80032

文件名: ubuntu_USN-2446-1.nasl

版本: 1.20

类型: local

代理: unix

发布时间: 2014/12/15

最近更新时间: 2024/1/9

支持的传感器: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent, Nessus

风险信息

VPR

风险因素: High

分数: 8.4

CVSS v2

风险因素: High

基本分数: 7.2

时间分数: 5.6

矢量: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS 分数来源: CVE-2014-9322

CVSS v3

风险因素: High

基本分数: 7.8

时间分数: 7

矢量: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

时间矢量: CVSS:3.0/E:P/RL:O/RC:C

漏洞信息

CPE: p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-43-generic, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-43-generic-lpae, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-43-lowlatency, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-43-powerpc-e500, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-43-powerpc-e500mc, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-43-powerpc-smp, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-43-powerpc64-emb, p-cpe:/a:canonical:ubuntu_linux:linux-image-3.13.0-43-powerpc64-smp, cpe:/o:canonical:ubuntu_linux:14.04:-:lts

必需的 KB 项: Host/cpu, Host/Ubuntu, Host/Ubuntu/release, Host/Debian/dpkg-l

可利用: true

易利用性: Exploits are available

补丁发布日期: 2014/12/12

漏洞发布日期: 2014/11/10

参考资料信息

CVE: CVE-2014-3673, CVE-2014-3687, CVE-2014-3688, CVE-2014-7825, CVE-2014-7826, CVE-2014-8134, CVE-2014-8369, CVE-2014-9090, CVE-2014-9322

BID: 70749, 70766, 70768, 70883, 70971, 70972, 71250

USN: 2446-1